🎅Richmond Christmas Parade forecast for Saturday

Apple warns some iPhone users: Update your phone or lose internet

If it ain’t broke, don’t fix it — right? Well, some of you Apple product users may not have a choice this weekend.

Apple is warning owners of older iPhones and iPads that if they don’t update their devices to the latest iOS software by Sunday, they won’t be able to connect to the internet.

IPhone and iPad products from 2012 and earlier will need the update before midnight UTC on November 3 in order to maintain accurate GPS location and continue using the App Store, iCloud, email and web browsing, according to Apple.

This is all because of the GPS time rollover issue, according to Apple, something that happens about every 19 years when GPS devices need to reset in order to accurately measure time and dates, according to the Office of Electricity at the Department of Energy.

Apple said during the last reset on April 6, GPS-enabled products from other manufacturers were affected.

So if you have an iPhone 5, 4, or a cellular-enabled iPad mini, iPad 2 or a third-generation iPad, this is for you.

The updated software version number should be 10.3.4 or 9.3.6, depending on your device.

iOS 10.3.4: iPhone 5 and iPad (4th generation) Wi-Fi + Cellular

iOS 9.3.6: iPhone 4s, iPad mini (1st generation) Wi-Fi + Cellular, iPad 2 Wi-Fi + Cellular (CDMA models only), iPad (3rd generation) Wi-Fi + Cellular

If you’re not sure which version your iPhone or iPad has, follow these directions:

1. Open the Settings app
2. Tap General, then tap About
3. Look for the number next to Software Version

If you’re not able to update your devices before Sunday, Apple said you’ll have to back up and restore using a computer because over-the-air software updates and iCloud Backup won’t work anymore.

Notice: you are using an outdated browser. Microsoft does not recommend using IE as your default browser. Some features on this website, like video and images, might not work properly. For the best experience, please upgrade your browser.